Credit History and Identity Check Service - Reduced Availability

Incident Report for MOQO

Resolved

Message from vendor:
---
The technical problems [...] are solved in the meantime.

The service was only partially available from Thursday, 25th June 2026 10:45AM CEST to Thursday, 25th June 2026 12:35AM CEST.
Posted Jun 25, 2026 - 11:39 UTC

Identified

We got a notification from our credit history and identity check service that they are facing temporary issues:

---
due to technical problems the service 'Digital Ident Check' is only partially available since

Thursday, 25th June 2026 10:45AM CEST.
---

Users might receive error messages when a history check is required but can not be performed.
Posted Jun 25, 2026 - 10:17 UTC
This incident affected: Backend-Systems (3rd party services).